Support Center

Setup and Installation

  • ViMove2 app system requirements

    ViMove2 is compatible with the following devices: Devices: Apple iPad models released in 2015 or newer. ...

    Mar 03, 2019 11:28PM UTC
  • ViMove2 software installation

    ViMove2 can be download from the Apple App Store on your compatible tablet device. To download the software, o...

    May 14, 2018 10:11AM UTC